Skip to end of metadata
Go to start of metadata

Prilikom pokušaja ažuriranja podataka o korisnicima ili dodavanja novog korisnika u LDAP imenik putem AOSI web sučelja u nekim se slučajevima (obično nakon reinstalacije aosi-aai ili openldap-aai paketa) javlja pogreška modifications require authentication!

Ta je pogreška izazvana činjenicom da je u konfiguracijskoj datoteci AOSI web servisa:


/etc/aosi/ldap_pwd


upisana neispravna zaporka LDAP administratorskog korisnika (onog korisnika čija se zaporka u kriptiranom obliku nalazi zapisana u slapd.conf konfiguracijskoj datoteci LDAP-a i čiji je dn: cn=admin,dc=domena,dc=hr). Dakle, ne radi se o fizičkoj osobi koja ima ovlasti administrirati podatke u LDAP imeniku (korisnik koji ima ovlasti ažurirati podatke putem web sučelja), nego o "sistemskom" korisniku.

Zaporka tog korisnika potrebna je AOSI web servisu kako bi se na LDAP mogao spojiti s administratorskim ovlastima i na taj način omogućiti da administrator imenika putem web sučelja (samo na osnovi vrijednosti atributa hrEduPersonRole) dobije pravo ažuriranja svih podataka u imeniku.

Pogrešku je moguće ispraviti na dva načina:

  1. Rekonfiguriranjem AOSI web servisa:

    Ako znate točnu zaporku gore opisanog administratorskog "sistemskog" korisnika, pokrenite naredbu:

    # dpkg-reconfigure aosi-aai

    i unesite ispravnu zaporku.

  2. Rekonfiguriranjem LDAP-a i AOSI web servisa:

    Ako ne znate koja je zaporka gore opisanog administratorskog "sistemskog" korisnika, zaporku najprije trebate postaviti u konfiguraciji LDAP-a naredbama:

    # dpkg-reconfigure slapd

    # dpkg-reconfigure openldap-aai

    i potom tu istu zaporku unijeti u konfiguraciju AOSI web servisa naredbom:

    # dpkg-reconfigure aosi-aai

  • No labels